icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.zzdhfm.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

乐购彩票 www.979840.com-彩票平台推广| www.341059.com-福彩双色球机兑奖| www.02iy.com-体彩排列五结果查询| www.580470.com-众发彩票害了多少人| www.34za.com-云购彩票彩种| www.63184.com-中国福利彩票365| www.239892.com-神彩88nmcc-| www.387311.com-尼彩i9-| www.683737.com-彩票平台app大全| www.818770.com-当彩票打票员视频| www.971392.com-特区七星彩海南论坛| www.in52.com-如何在手机上买彩票| www.22xb.cc-彩票投注网站在哪找| www.2466.in-福利彩票3d布衣图| www.24845.com-体彩宝-| www.013293.com-特区网七星彩论坛| www.119030.com-体育彩票是什么| www.qm07.com-乐彩33众飞-| www.93ei.com-博彩对赌套利靠谱吗| www.6588.me-彩16可靠吗-| www.69413.com-乐彩28-| www.163671.com-时时彩如何容错最稳| www.365379.cc-v9彩票注册-| www.717820.com-2019彩图-| www.875242.com-彩经网p3走势图| www.lu78.cc-大中华彩票彩种| www.539115.com-时时彩杂六有哪些| www.03fd.cc-八卦预测彩票取数法| www.640115.com-新浪爱彩无法提现| www.785621.com-彩票3d数据分析| www.875009.com-福彩20选8陕西| www.980806.com-彩票店兑奖有提成吗| www.kn0.com-福彩快三改版| www.rn56.com-福彩8软件-| www.05ol.com-自学彩铅画教材| www.89cx.com-私彩后庄怎么量刑| www.6580.vip-聚鑫彩-| www.28755.com-快彩平台-| www.81544.com-博彩被骗了怎么办| www.080066.cc-玩彩票有什么规律| www.ap98.com-星彩体育彩票| www.311503.com-11选五爱彩乐辽宁| www.879811.com-购彩网正规吗| www.16366.cc-彩客站大发快| www.037745.com-七乐彩在线选号工具| www.365145.cc-体彩弃奖-| www.879249.com-网购彩票体彩| www.991924.com-时时彩定胆不错方法| www.pf03.com-河北快三技巧宝典| www.24gm.com-贴钢化膜和彩膜| www.7531.pw-给彩票业主交社保| www.51765.cc-福彩三b开机号| www.132415.com-河南要彩礼-| www.291830.com-上海时时乐彩控| www.472163.com-福彩22选五开奖号| www.657195.com-广州时时彩-| www.922679.com-白小姐旗袍2彩图| 500彩票www.346577.com| www.wq88.com-快三走势图带连线| www.95ty.com-快三春节开奖吗| www.5137.cc-广州福彩网官方网站| www.50483.cc-湛江加急七星彩版| www.024234.com-新福利彩票543站| www.127605.com-彩虹玫瑰能种出来吗| www.258602.com-竞彩资讯-| www.408330.com-七星彩历史最低奖| www.740741.cc-港股中的博彩股| www.874234.com-大厅彩票源码| www.193121.com-长春逸彩快三查询| www.293787.com-江苏老快三一定| www.645320.com-35彩票app安卓| www.839015.com-竞彩分析软件好用吗| 361彩票www.361gc.com| www.yw02.com-云南省彩票中心位置| www.200.bid-盈彩的意思是什么| www.6246.me-福彩3d定位词| www.38523.com-云购彩8-| www.024571.com-河北福彩快3推| www.142871.com-鼎盛时时彩-| www.276265.com-时时彩票走势怎么看| www.414121.com-古代纳彩大雁| www.552090.com-众盈彩票app| www.705163.com-体彩跨省能兑奖吗| www.969222.com-天天彩票骗局| www.ut46.com-网易彩票幸运选号| www.085338.com-彩票论坛微信公众号| www.207599.com-彩3d之家-| www.305500.com-彩票杂选号-| www.398557.com-刚开的七星彩| www.20vh.com-有选一个号的彩票吗| www.yb16.com-福彩3d34期-| www.54qx.com-体彩金孔雀顶呱呱| www.071128.com-彩妆店名-| www.190807.com-江苏快三时间调整| www.338472.com-香蕉计划彩票软件| www.452567.com-com.彩78-| www.672522.com-排列三手机彩宝网| www.791527.com-马来西亚博彩诈骗案| www.899471.com-彩神通软件app| www.974772.com-广州体彩网官网首页| www.in3.com-内蒙快三规律| www.2753.wang-快三倍数怎样赚钱| www.10000.cc-国际极速彩票| www.78651.cc-彩经网排三最大值| www.055050.com-有什么彩票网站推荐| www.8512.top-派彩网陕西快乐十分| www.77894.com-福利彩票客服| www.082039.com-恒博彩票是真的吗| www.798135.com-海南省福利彩票官网| www.889283.com-彩票世界app| www.965921.com-易发彩网-| www.ay31.com-福彩积分-| www.c49.in-306官方彩票苹果| www.958.tv-够力辣椒七星彩奖表| www.585688.com-足球彩票今天场次| www.296863.com-惠民彩票平台登录| www.427634.com-足彩任九过滤技巧| www.12315.com-彩票中奖后有效期| www.72295.cc-886彩票-| www.075362.com-七乐彩双期走势图| www.176463.com-彩票群主带计划| www.7381.vip-懂球帝可以买彩票吗| www.968641.com-重视时时彩微信群| www.553119.com-福利快三群-| www.2564.org-足彩十四场比分之5| www.9850.org-太和殿彩画-| www.55920.com-彩票170com| www.015230.com-七星彩经-| www.121640.com-合买彩票的网站| www.3296.biz-彩色简笔画风景| www.73969.com-彩票输改赢软件代码| www.081991.com-快三破解器软件下载| www.219690.com-彩票投注经验| www.405093.com-七星彩专家杀号定位| www.898257.com-河南福彩扫一扫下载| 七彩www.53900q.com| www.0049.net-网上买彩票方式| www.zw75.com-广西福彩选号器下载| www.fh81.com-高德彩诈骗-| www.798669.com-带vip的彩票平台| 500万彩票www.500cd.com| www.799555.com-彩票运势姓名生日| www.892877.com-大嬴家彩票app| www.976567.com-福建彩礼价格表| www.8970.org-天津时时彩最新漏洞| www.031291.com-足球彩票算不算赌博| www.mq05.com-彩神网页版登录| www.516397.com-王成周研究彩票视频| www.34809.com-qq彩票竞猜技巧| www.859231.com-6加1彩票开奖结果| www.137.link-送彩虹屁-| www.52sn.com-香港49码彩票直播| www.4932.cc-彩票打码量是什么| www.281078.com-足彩串场奖金计算| www.385510.com-彩宝贝走势-| www.476601.com-双色球牛彩专家杀号| www.906773.com-cp577彩票平台| 500彩票www.50052k.com| www.196778.com-七乐彩中奖金额表| www.333136.com-5分彩选号技巧| www.034953.com-彩68完整源码| www.369745.com-博中彩票网址| www.585242.com-彩神5分快三| www.621308.com-红旗彩票能玩吗|